[求助]在AppServ下架設CGI程式,會不要暴衝到MYSQL

edited 十月 2013 in 伺服器環境
1.網站網址-- http://hi17168.no-ip.org/(網站改版中..未開伺服器)
2.OS種類版本-- win2000
3.AppServ版本--2.4.0
4.MySQL版本-- 4.0.18
5.Apache版本-- 1.3.29
6.PHP版本-- 4.3.6
7.Perl版本--5.8.7.813

KIANG兄您好(各位網友大家好)...我又出現了..呵呵

抱歉..這次又遇到疑問....終於又浮上岸了.....

小弟最近突然心血來潮..想把以前所練得的CGI功力,拿來與

XOOPS(PHP)融合貫通..來替網站增加一些內容

原則上..架設到運作,應該是沒問題

我的疑問是...在Apache下執行CGI時,有沒有可能去干擾或影響

到MYSQL的運作(基本上我瞭解CGI沒經過MYSQL)但是在同一

伺服器下去跑..有無可能因為CGI讀寫太頻繁,去衝到MYSQL?

另一個問題是...最近我在研究並收集一些有關XOOPS無法顯示

頁面..或無法登入管理員..或一些自架網站常見的問題..發覺到一點

那些問題都不是出在XOOPS原本系統中..經過仔細核對,發現出問題

的網站..超過9成都是使用AppServ2.4.0的版本

現在因為沒證據..我也不敢去亂製造謠言..所以想請教一下...

AppServ2.4.0要如何升級到AppServ版本--2.4.3啊....

抱歉..因為搜尋了3天..找遍了相關字..都還是找不到教學

期待諸位前輩們..再次幫小弟解惑...感謝您

原始討論: http://twpug.net/x/modules/newbb/viewtopic.php?topic_id=929

評論

  • edited 十月 2005
    1. 理論上CGI+PHP是不會互相干涉,不過同一台主機上的服務越多就越難穩定
    2. 升級比較建議的方式是先備份,接著移除舊版本(這時候資料並不會被清除),然後裝上新版本,接著確定看看有沒有問題,出問題就用備份的資料還原
Sign In or Register to comment.