有關MYSQL版本問題

edited 十月 2013 in 資料庫
請教一下各位大大

我最近正再編寫一個網頁系統

我所採用的語法是PHP5以上的

資料庫採用的也是最新版的(開發環境)

但結果因為公司所採用的的資料庫是舊版的而導致資料庫無法連結

後來在網頁系統上的資料庫設定元件上面將程式碼改成PHP3舊版的聯結還是連結

請問一下如果要在資料庫不升級狀態下我的網頁設計該如何聯結資料庫呢??

原始討論: http://twpug.net/x/modules/newbb/viewtopic.php?topic_id=5810

評論

  • edited 三月 2011
    呃..我想這要釐清一些問題
    1.PHP版本
    2.MySQL版本

    是否有升級可能?
    不過升級可能意味著需要翻架構PHP3->PHP5,語法的差異太大
    這可能是比較理想的做法,PHP4以下的環境已經不適合使用
    當然..選擇這條路的話就需要大量修改原程式,最糟的狀況根本是全部重寫
    如果選擇在PHP3下繼續擴充..說真的還真不知道要到哪裡去挖出上個世紀的開發工具呢...
  • edited 三月 2011
    我本身製作環境是PHP5 MYSQL好像是4.0以上的

    但是我的網頁系統未來要移植到MSQL4.0以下的

    且現在未來的資料庫是無法升級的

    所以才想要請教一下

    如果資料庫無法升級的狀態下是否可以連結的到
  • edited 三月 2011
    好玩好玩了
    我剛剛去查詢一下我的資料庫版本
    結果兩個版本都是5.0以上的
    那這樣讓我更頭痛了
    這兩個放在分別不同的伺服器
    總共我分為A和B是資料庫的伺服器
    A是我未來的資料庫
    B是我現在開發環境的資料庫
    再來就是再分一個C是我未來的網頁系統的伺服器
    好玩的地方在這
    C可以連到B但是連不到A
    且A的版本還比B新
    同樣的程式語言且有那麼大的差別
    請問大大我那裡做錯了
    可以給我指教一下嗎
Sign In or Register to comment.