appsvr 安裝在iis既存在的環境下遇到的問題

edited 十月 2013 in 伺服器環境
如標題!我在一台已存在iis的主機上安裝appsvr最新版本的套件(2.5.10),結果搞了半天好不容易在localhost可以順利的看到展示畫面,但是在打入localhost/phpmyadmin時確會出現錯誤訊息「無法讀取 mysql 模組,<br />請檢查 PHP 設定」,這範圍挺廣的錯誤= =
目前已經爬文確定過php.ini的設定是對的
請問我還能檢查拿裡來解決這個問題呢?


原始討論: http://twpug.net/x/modules/newbb/viewtopic.php?topic_id=4093

評論

  • edited 四月 2009
    很顯然mysql模組還是沒掛上去
    appsvr去裝的話我記得兩個php.ini都要改吧
    你要確定C:\windows\system32\下的php.ini也有改喔
    嗯..改完後要記得reset apache(炸
  • edited 四月 2009
    @"
    我在另一台正常的電腦上也一樣沒發現存在著這個東東 ├140┤
  • edited 四月 2009
    那你再找一下c:\windows\
    不然就要改regedit了
  • edited 四月 2009
    也許是 appserv ?不妨先放一個檔案到網頁目錄,裏面只有 <?php phpinfo(); 這樣的內容,透過瀏覽器輸入本地端網址將它打開(像 http://localhost/test.php ),裏面就會告訴你 php.ini 在哪裡。
  • edited 四月 2009
    kiang 大
    我在http://localhost 是可以正常的看到我的網頁,我也可以透過修改php.ini的路徑讓我的網站正常的顯示,可是透過 http://localhost/phpmyadmin 要進去設定資料庫時就會出現以下的訊息:
    「phpMyAdmin - 錯誤
    無法讀取 mysql 模組,<br />請檢查 PHP 設定 - 說明文件」

    說明文件點了的解釋也是如下:
    「1.20 I receive the error "cannot load MySQL extension, please check PHP Configuration".
    To connect to a MySQL server, PHP needs a set of MySQL functions called "MySQL extension". This extension may be part of the PHP distribution (compiled-in), otherwise it needs to be loaded dynamically. Its name is probably mysql.so or php_mysql.dll. phpMyAdmin tried to load the extension but failed.

    Usually, the problem is solved by installing a software package called "PHP-MySQL" or something similar.」

    我檢查了phpmyadmin 裡面的 config.inc.php 跟 php 裡面的 php.ini 還有透過 mysqlcommand 去檢查都沒有找到問題所在,這著實令我頭痛呀.....

    希望有遇過的大大能協助解答一下 囧rz
  • edited 四月 2009
    找php.ini裡
    extension_dir=你的模組路徑
    然後去這個路徑確認一下有沒有
    php_mysql.dll
    這個檔案就是mysql模組
    如果沒有當然載不進去
    然後搜尋出這個檔copy過去
    如果搜尋不到.就去官方抓這模組回來
    問題發生點並不一定是主因
    因為你不夠瞭解是怎麼運做的.所以只有一步一步查了...
  • edited 四月 2009
    SoltyRain 大
    您的一句話點亮了我的慧根!
    原來appsvr在預設安裝時,把php.ini寫入到C:\document and setting\nuser\windows裡面,由於並不是存在於C:\windows底下,所以phpmyadmin的路徑一直對應不到(其實也是可以變更讀取路徑來解決此問題!),但是不經一事不長一智!謝謝SoltyRain大的指引!這個問題解決了~!
Sign In or Register to comment.