求助詢問:appserv-win32-2.4.3的安裝問題

edited 十月 2013 in PHP新手區
站大及前輩們好,一般在使用XOOPS架站前,都會先安裝伺服器軟體,我選擇了appserv最新版的appserv-win32-2.4.3來架站(作業系統W2K)但是我都按照步驟一步一步安裝,但是在進入資料庫時,由於安全性考量,都會建議更改root管理員的登入密碼,也有去修改登入資料庫的方式,我也照做了,但是問題是,我用瀏覽器想要登入資料庫時,卻發生使用者及密碼錯誤,拒絕我登入,請問這是什麼原因,是因為這個版本的問題呢?還是我本身作業系統的問題(我都有按照書上的只是及該套件的作法進行),還是說有哪位站大能夠提供在W2K環境中獨立架設伺服器軟體(apache1.XX+PHP4.3.10+MYSQL3.XX+phpMyAdmin2.5.7)的作法?

原始討論: http://twpug.net/x/modules/newbb/viewtopic.php?topic_id=409

評論

  • edited 二月 2005
    1. 花點時間看看 phpMyAdmin 中的設定檔案

    2. 獨立安裝的做法可以參考相關書籍
  • edited 四月 2005
    我也是遇到跟第一位使用者發表的問題一樣,也都是按照程序來安裝,也去過phpMyAdmin裡將config的字眼改成http,不過就會遇到資料庫錯誤及拒絕存取的問題,我也很想知道怎麼解決,或者可以獨立安裝的方式,因為appserv一直將新的東西包含在裡面,但是有些獨立元件要個別更新卻很麻煩,請問可以推薦哪本書上有寫到如何在WINDOWS上分別架設(apache1.XX+PHP4.3.10+MYSQL3.XX+phpMyAdmin2.5.7)(因為資料庫不想安裝4.X版的)(只是想更新PHP版本,發覺很困難)
    煩請站大告知實際且有效的解決方案,或是在appserv這個軟體如何只更新PHP版本(因為我嘗試用先前覆蓋的方式不行,去PHP官站下載新的元件安裝,可是他好像只針對IIS使用吧?可是我裝的是APACHE,所以會出現安裝錯誤裝不起來無法覆蓋更新)
    謝謝站大並感謝你的辛苦!
  • edited 四月 2005
    Appserv只是一個輔助工具,安裝完後其實跟獨立安裝各個元件沒有兩樣,最大的差別可能在於你無法直接透過新增/移除程式的方式去個別管理;我並沒有嘗試過直接更新AppServ所安裝的PHP,但是印象中直接覆蓋、修改設定檔案即可,細節可能要有經驗的朋友才能回答,我大部分是在LINUX下使用。

    PHP官方網站的WINDOWS軟體包裝基本上沒有特別針對哪個伺服器,無法使用可能只是設定的問題。
Sign In or Register to comment.