附加檔案時發生錯誤

Warning: move_uploaded_file(d:\appserv\www\vtigercrm//test/upload/123.jpg): failed to open stream: Invalid argument in d:\appserv\www\vtigercrm\modules\uploads\add2db.php on line 32

Warning: move_uploaded_file(): Unable to move 'C:\WINDOWS\TEMP\php200.tmp' to 'd:\appserv\www\vtigercrm//test/upload/123.jpg' in d:\appserv\www\vtigercrm\modules\uploads\add2db.php on line 32


大大~我有遇到一個問題了,我在聯絡人那附加一個檔案時發生了這樣子的錯誤,是否有方法可以解決呢?另外再詢問一個問題,就是所建立聯絡人的檔案會儲存在那個檔案內呢?路徑為何?那備份的機制為何?如何備份?感謝~

原始討論: http://twpug.net/x/modules/newbb/viewtopic.php?topic_id=1161

評論

  • edited 一月 2006
    我這邊測試正常, vtigercrm/test/upload 這個目錄可能有問題吧

    資料大多儲存在資料庫,備份整個程式與資料庫就可以了。
  • edited 一月 2006
    kiang 寫道:
    我這邊測試正常, vtigercrm/test/upload 這個目錄可能有問題吧

    資料大多儲存在資料庫,備份整個程式與資料庫就可以了。


    大大~我發現啊,應該不是哦,我今天有在弄一次,我的方式是:我一開始先建一個新的使用者(原先以為是使用者的問題),因為第一次設好之後上傳就可以了,後來發現應該不是,應該是上傳中文的關系,它好像不太能接受中文的檔案(之所以會說不太能是因為我有用傳一個中文名稱的檔案),之後測的就都只能用英文的名稱上傳了(不知道這算不算bug),另外~~大大~它有限制上傳的檔案大小,不知您知道如何更改它的大小嗎?在那改呢?
  • edited 一月 2006
    vtigercrm/config.php 裡面的 $upload_maxsize

    php.ini 的設定也要跟著改
  • edited 二月 2006
    kiang大大~~

    我在使用上傳(附檔)時,能正常上傳(我傳的是照片),但是按它時,它無法正常的顯示出來,而是要到資料夾裡開起,請問這部份是那裡出了問題~!
  • edited 二月 2006
    1. vtigerCRM 版本?
    2. 在哪個畫面的哪個動作上傳檔案?
    3. 點選後無法正常顯示是什麼意思?
  • edited 二月 2006
    1.我使用的是vtiger_crm_4.2.3_zh-tw.zip這個程式。
    2.動作是:聯絡人->聯絡人列表進入->最下面有一個附檔->上傳之後再選它並無顯示。
    3.顯示:是因為我上傳的檔案是照片檔(.jpg),所以不管我是在上面開起或是下載開起都無法顯示照片。

    不好意思之前沒有詳述。
  • edited 二月 2006
    我試著操作後沒發現同樣問題,你的 AppServ 版本為何?

    我是使用 AppServ 2.4.4a
  • edited 二月 2006
    我是使用:appserv-win32-2.3.0.exe這個。
  • edited 二月 2006
    我不確定問題為何,只知道目前在我的環境中測試正常;有其他的環境遇到類似問題嗎?
Sign In or Register to comment.