建立phplist伍虎將軟體建置環境時-伺服器如何挑選版本!?

edited 十月 2013 in 電子商務
小弟購買phplist五虎將,想要將這5套軟體-建置在同一台主機上,採用winxp2平台 伺服器採用appach,請問我應該採用哪各版本可以同時建置不會有問題!?(不懂linux的作業系統)
1.AppServ 2.4.5
2.AppServ 2.4.4a Packages(穩定版)
還是那一個版本教適合!??作為知識管理平台!

請各位先知可否告知!?

謝謝---peter

原始討論: http://twpug.net/x/modules/newbb/viewtopic.php?topic_id=1079

評論

  • edited 十二月 2005
    如果要全部安裝,建議安裝在 Linux 上面,因為許多功能在 Windows 上面不是不能執行就是需要手動調整程式碼。

    至於 AppServ 的版本,基本上只要是 2.4.x 就可以了,不妨使用最新的 2.4.5 。

    對了...書籍名稱是 PHP五虎將 ...
  • edited 十二月 2005
    不好意思打把書名記成電子報的名稱!

    我原先架設的環境是:AppServ 2.4.1-資料庫安裝過程中是選擇BIG5語系
    如果要選擇UTF-8語系,安裝屬於UTF-8的XTC,XOOPS2,egroupware ...等-最好的方式是:

    1.移除appserv2.41 從新安裝appserv2.45!?

    2.打開http://localhost/PHPMYADMIN/index.php--去修改語言的選項成 utf-8(但是我修改完成-utf-8後,但是過一段時間又會自動跑回big5),是否可行!??如果可行--應該要修改何處!??-變成utf-8系統

    3.我在安裝moodle1.53,xtc3.03,xooos2.2.3a ,VTIGER4.2,utf-8版的時候,會把 http://localhost/PHPMYADMIN/ 資料庫的語系 改成繁體的utf-8,結果程式也可以安裝起來(不過心中友疑惑,這樣的安裝方式正確嗎!???),而且可以執行,只有VTIGER4.2 不能進入--設定/系統環境設定--這各選項,其他的皆正常!!--這樣以後在網站在運行過程中是否會發生不可預期的錯誤呢!???

    請kiang老師 解決心中的疑惑!

    謝謝
    peter ├151┤
  • edited 十二月 2005
    1. 如果只是測試環境就不需要,如果有對外開放建議可以更新到這個版本,因為舊版PHP有些安全上的問題。

    2. phpMyAdmin 只是一個管理介面,在它上面的設定大多不會影響資料庫本身,除非嘗試修改資料庫架構等

    3. VTIGER4.2可能是安裝過程問題造成它無法順利運行,基本上資料庫選擇什麼樣的編碼並不會影響一般的操作。
Sign In or Register to comment.